import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:[A-Za-z]{1,3}\\d{0,10})(?::(?:[A-Za-z]{1,3}\\d{0,10}))?$";
final String string = "A1\n"
+ "A1:C4\n"
+ "AB:AB\n"
+ "1:1 # don't match";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}