package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:[A-Za-z]{1,3}\d{0,10})(?::(?:[A-Za-z]{1,3}\d{0,10}))?$`)
var str = `A1
A1:C4
AB:AB
1:1 # don't match`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}