#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "Scheduled\s+:\s+(?<Field_Name>.+)\s+Rep"
Local $sString = "9/8/17" & @CRLF & _
"8:30:01.598 PM " & @CRLF & _
"2017-09-08T20:30:01.598-04:00 INFO m_gchgserv_gchg.cpp(2264)[9] GCHG::sendGchgUpdate() - 105971244 type: 1 note: In-Progress {FIFW GCHG 167015}: Install power supply" & @CRLF & _
"Scheduled : 09/09/2017 00:30 GMT to 09/09/2017 03:30 GMT" & @CRLF & _
"Rep : Mike Sunil" & @CRLF & _
"Note: Install power supplies"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")