re = /Scheduled\s+:\s+(?<Field_Name>.+)\s+Rep/
str = '9/8/17
8:30:01.598 PM
2017-09-08T20:30:01.598-04:00 INFO m_gchgserv_gchg.cpp(2264)[9] GCHG::sendGchgUpdate() - 105971244 type: 1 note: In-Progress {FIFW GCHG 167015}: Install power supply
Scheduled : 09/09/2017 00:30 GMT to 09/09/2017 03:30 GMT
Rep : Mike Sunil
Note: Install power supplies'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end