import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Scheduled\\s+:\\s+(?<Field_Name>.+)\\s+Rep";
final String string = "9/8/17\n"
+ "8:30:01.598 PM \n"
+ "2017-09-08T20:30:01.598-04:00 INFO m_gchgserv_gchg.cpp(2264)[9] GCHG::sendGchgUpdate() - 105971244 type: 1 note: In-Progress {FIFW GCHG 167015}: Install power supply\n"
+ "Scheduled : 09/09/2017 00:30 GMT to 09/09/2017 03:30 GMT\n"
+ "Rep : Mike Sunil\n"
+ "Note: Install power supplies";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}