#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^(?:[\dA-Z-]+\.(?:jpe?g|png|gif))?(?:, (?:[\dA-Z-]+\.(?:jpe?g|png|gif)))*$"
Local $sString = "bad_image.jpg" & @CRLF & _
"" & @CRLF & _
"2017-06-01-03-55-00-5930782c5c0b1.jpg" & @CRLF & _
"2017-06-01-03-55-00-5930782c5c0b1.jpeg, bad_image.jpg" & @CRLF & _
"2017-06-01-03-55-00-5930782c5c0b1.png, 2017-06-01-03-55-00-5930782c5c0b1.gif" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")