package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^(?:[\dA-Z-]+\.(?:jpe?g|png|gif))?(?:, (?:[\dA-Z-]+\.(?:jpe?g|png|gif)))*$`)
var str = `bad_image.jpg
2017-06-01-03-55-00-5930782c5c0b1.jpg
2017-06-01-03-55-00-5930782c5c0b1.jpeg, bad_image.jpg
2017-06-01-03-55-00-5930782c5c0b1.png, 2017-06-01-03-55-00-5930782c5c0b1.gif
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}