const regex = /^(?:[\dA-Z-]+\.(?:jpe?g|png|gif))?(?:, (?:[\dA-Z-]+\.(?:jpe?g|png|gif)))*$/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:[\\dA-Z-]+\\.(?:jpe?g|png|gif))?(?:, (?:[\\dA-Z-]+\\.(?:jpe?g|png|gif)))*$', 'gmi')
const str = `bad_image.jpg
2017-06-01-03-55-00-5930782c5c0b1.jpg
2017-06-01-03-55-00-5930782c5c0b1.jpeg, bad_image.jpg
2017-06-01-03-55-00-5930782c5c0b1.png, 2017-06-01-03-55-00-5930782c5c0b1.gif
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}