#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:^.*\R?){1,20}"
Local $sString = "Clip 08.jpg" & @CRLF & _
"Clip 31.jpg" & @CRLF & _
"Clip 31b.jpg" & @CRLF & _
"Clip 32.jpg" & @CRLF & _
"Clip 40.jpg" & @CRLF & _
"Clip 40b.jpg" & @CRLF & _
"Clip 53.jpg" & @CRLF & _
"Clip 54.jpg" & @CRLF & _
"Maui Clip 53b.jpg"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")