import re
regex = re.compile(r"(?m)(?:^.*\R?){1,20}")
test_str = ("Clip 08.jpg\n"
"Clip 31.jpg\n"
"Clip 31b.jpg\n"
"Clip 32.jpg\n"
"Clip 40.jpg\n"
"Clip 40b.jpg\n"
"Clip 53.jpg\n"
"Clip 54.jpg\n"
"Maui Clip 53b.jpg")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")