import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?m)(?:^.*\\R?){1,20}";
final String string = "Clip 08.jpg\n"
+ "Clip 31.jpg\n"
+ "Clip 31b.jpg\n"
+ "Clip 32.jpg\n"
+ "Clip 40.jpg\n"
+ "Clip 40b.jpg\n"
+ "Clip 53.jpg\n"
+ "Clip 54.jpg\n"
+ "Maui Clip 53b.jpg";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}