import re
regex = re.compile(r"^[^\/]*(\/.*?):(.*)$", flags=re.MULTILINE)
test_str = ("dregistry.service.local:4000/msi/paas-cluster-manager:2.2.141401\n"
"dregistry.service.local:4000/paas-cluster-manager:2.2.141401")
subst = "\\1"
result = regex.sub(subst, test_str)
if result:
print(result)