// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\D+[A-Z]+").unwrap();
let string = "ZWARTEBERGLAAN 6
'T KLOOSTERHOF 34
34 JAN HAMMENECKERSTRAAT
JAN HAMMENECKERSTRAAT 34
CHEMIN DE P'TIT ROUGE 6
AVENUE HENRI DE BROUCK�RE 31
L.A. SCHOOKLAANSTRAAT 42
HUIDEVETTERKEN 9-11-13-13 9
KONINGIN ASTRIDSTRAAT 316
BOULEVARD SAINT MICHEL 113//115 Verd.3
ANTWERPSESTEENWEG 83/101 Verd.1
AVENUE EMILE MAX 75 Verd.RC";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}