import Foundation
let pattern = #"\D+[A-Z]+"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
ZWARTEBERGLAAN 6
'T KLOOSTERHOF 34
34 JAN HAMMENECKERSTRAAT
JAN HAMMENECKERSTRAAT 34
CHEMIN DE P'TIT ROUGE 6
AVENUE HENRI DE BROUCK�RE 31
L.A. SCHOOKLAANSTRAAT 42
HUIDEVETTERKEN 9-11-13-13 9
KONINGIN ASTRIDSTRAAT 316
BOULEVARD SAINT MICHEL 113//115 Verd.3
ANTWERPSESTEENWEG 83/101 Verd.1
AVENUE EMILE MAX 75 Verd.RC
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)