const regex = /^(?=[A-Z0-9]{10}$)[A-Z1-9]*0+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=[A-Z0-9]{10}$)[A-Z1-9]*0+$', 'gm')
const str = `ABC1000000
3212130000
0000000000
ABC1000100
0001000000`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}