$re = '/^(?=[A-Z0-9]{10}$)[A-Z1-9]*0+$/m';
$str = 'ABC1000000
3212130000
0000000000
ABC1000100
0001000000';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);