re = /^(?=[A-Z0-9]{10}$)[A-Z1-9]*0+$/m
str = 'ABC1000000
3212130000
0000000000
ABC1000100
0001000000'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end