const regex = /[^\s<>]+(?![^<]*>)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[^\\s<>]+(?![^<]*>)', 'gm')
const str = `<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd"><html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en"><head><meta http-equiv="Content-Type" content="text/html;" /><title>Email Newsletter</title></head><body style="font-family: Helvetica, Arial, sans-serif; font-size: 12px">
<p><span style="font-size:14px;"><span style="font-family:arial,helvetica,sans-serif;">Hi %%first_name%% - hope you can join us!<br>
<br>
<a href="https://xfinityflowershow.rsvpify.com/"><img alt="" border="0" height="525" src="http://go.pardot.com/l/292992/2019-02-26/3yvjz3/292992/83766/FlowerShow_Invite_V4.jpg" style="height: 525px; width: 700px; border-width: 0px; border-style: solid;" width="700"></a><br>
<br>
Regards,<br>
%%user_name%%<br>
%%user_email%%<br>
Comcast</span></span><br>
<br>
<br>
<br>
<br>
<br>
<br>
<span style="font-size:10px;"><span style="font-family:arial,helvetica,sans-serif;">If you have received this communication in error or would like to unsubscribe, please click <a href="%%unsubscribe%%">here</a>. </span></span></p>
</body></html>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}