use strict;
my $str = '<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd"><html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en"><head><meta http-equiv="Content-Type" content="text/html;" /><title>Email Newsletter</title></head><body style="font-family: Helvetica, Arial, sans-serif; font-size: 12px">
<p><span style="font-size:14px;"><span style="font-family:arial,helvetica,sans-serif;">Hi %%first_name%% - hope you can join us!<br>
<br>
<a href="https://xfinityflowershow.rsvpify.com/"><img alt="" border="0" height="525" src="http://go.pardot.com/l/292992/2019-02-26/3yvjz3/292992/83766/FlowerShow_Invite_V4.jpg" style="height: 525px; width: 700px; border-width: 0px; border-style: solid;" width="700"></a><br>
<br>
Regards,<br>
%%user_name%%<br>
%%user_email%%<br>
Comcast</span></span><br>
<br>
<br>
<br>
<br>
<br>
<br>
<span style="font-size:10px;"><span style="font-family:arial,helvetica,sans-serif;">If you have received this communication in error or would like to unsubscribe, please click <a href="%%unsubscribe%%">here</a>. </span></span></p>
</body></html>';
my $regex = qr/[^\s<>]+(?![^<]*>)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}