package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(?<time>(?:\d{2}:){2}\d{2}\.\d{3} [^\s]*) : (?<message2>[^ \]]*)\] (?<message3>[^ \]]*)\] (?<message4>[^ \]]*)\] (?<message5>[^ \]]*)\] (?<severity>\w+)\s+(?<log2222>.*)`)
var str = `23:02:32.000 17-Oct-2017;04:36:29.744 : [main] [server:] [id:] [yt:] ERROR no.myproject.service.Server - call failed for some reason`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}