const regex = /^(?<time>(?:\d{2}:){2}\d{2}\.\d{3} [^\s]*) : (?<message2>[^ \]]*)\] (?<message3>[^ \]]*)\] (?<message4>[^ \]]*)\] (?<message5>[^ \]]*)\] (?<severity>\w+)\s+(?<log2222>.*)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?<time>(?:\\d{2}:){2}\\d{2}\\.\\d{3} [^\\s]*) : (?<message2>[^ \\]]*)\\] (?<message3>[^ \\]]*)\\] (?<message4>[^ \\]]*)\\] (?<message5>[^ \\]]*)\\] (?<severity>\\w+)\\s+(?<log2222>.*)', 'g')
const str = `23:02:32.000 17-Oct-2017;04:36:29.744 : [main] [server:] [id:] [yt:] ERROR no.myproject.service.Server - call failed for some reason`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}