import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?<time>(?:\\d{2}:){2}\\d{2}\\.\\d{3} [^\\s]*) : (?<message2>[^ \\]]*)\\] (?<message3>[^ \\]]*)\\] (?<message4>[^ \\]]*)\\] (?<message5>[^ \\]]*)\\] (?<severity>\\w+)\\s+(?<log2222>.*)";
final String string = "23:02:32.000 17-Oct-2017;04:36:29.744 : [main] [server:] [id:] [yt:] ERROR no.myproject.service.Server - call failed for some reason";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}