import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "from group (\\d+)(?:(?!Temp).)*?(Temp)?(?:(?!Temp).)*?\\\\t(.*? ALL-..)";
final String string = "{\"show permission allowed to 16\": \"show permission to 16\\\\nSchool permissions from group 17:student to group 16:teacher:\\\\n\\\\tAllow ALL-00\\\\nSchool permissions from group 18:library to group 16(Temp):teacher:\\\\n\\\\tNo Allow ALL-00\\\\nSchool permissions from group 20:Gym to group 16:teacher:\\\\n\\\\tCheck ALL-00\\\\nRTYAHY: FALSE\\\\nRTYAHY: FALSE\\\\n\\\\n#\"}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}