re = /from group (\d+)(?:(?!Temp).)*?(Temp)?(?:(?!Temp).)*?\\t(.*? ALL-..)/m
str = '{"show permission allowed to 16": "show permission to 16\\\\nSchool permissions from group 17:student to group 16:teacher:\\\\n\\\\tAllow ALL-00\\\\nSchool permissions from group 18:library to group 16(Temp):teacher:\\\\n\\\\tNo Allow ALL-00\\\\nSchool permissions from group 20:Gym to group 16:teacher:\\\\n\\\\tCheck ALL-00\\\\nRTYAHY: FALSE\\\\nRTYAHY: FALSE\\\\n\\\\n#"}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end