#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^\*<font color="#ffff00">(.*?)<\/font>"
Local $sString = "*<font color="#ffff00">Blue Moon Frogurt</font> <font color="#ffffff">(Unlocked on Rank 116 with <font color="#ffff00">'''''Unrevealed Contest Entry'''''</font><font color="#ffffff">)</font>" & @CRLF & _
"*<font color="#ffff00">Shadowberry Derps</font> <font color="#ffffff">(Unlocked on Day 2 of <font color="#ffff00">Summer Solstice</font><font color="#ffffff">)</font>" & @CRLF & _
"*<font color="#ffff00">Golden Solstice Truffle</font> <font color="#ffffff">(Unlocked on Rank 117 with <font color="#ffff00">?</font><font color="#ffffff">)</font>"
Local $sSubst = "*[[$1|<font color="#ffff00">$1</font>]]"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)