import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\*<font color=\"#ffff00\">(.*?)<\\/font>";
final String string = "*<font color=\"#ffff00\">Blue Moon Frogurt</font> <font color=\"#ffffff\">(Unlocked on Rank 116 with <font color=\"#ffff00\">'''''Unrevealed Contest Entry'''''</font><font color=\"#ffffff\">)</font>\n"
+ "*<font color=\"#ffff00\">Shadowberry Derps</font> <font color=\"#ffffff\">(Unlocked on Day 2 of <font color=\"#ffff00\">Summer Solstice</font><font color=\"#ffffff\">)</font>\n"
+ "*<font color=\"#ffff00\">Golden Solstice Truffle</font> <font color=\"#ffffff\">(Unlocked on Rank 117 with <font color=\"#ffff00\">?</font><font color=\"#ffffff\">)</font>";
final String subst = "*[[$1|<font color=\"#ffff00\">$1</font>]]";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}