$re = '/^(?:\d+\*\d*(?:\.\d*)? ?)*$/m';
$str = '1*10 5*50 13*250 5*50 1*10
3*33.33 4*25 3*33.33';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);