// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:\d+\*\d*(?:\.\d*)? ?)*$").unwrap();
let string = "1*10 5*50 13*250 5*50 1*10
3*33.33 4*25 3*33.33";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}