re = /^(?:\d+\*\d*(?:\.\d*)? ?)*$/m
str = '1*10 5*50 13*250 5*50 1*10
3*33.33 4*25 3*33.33'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end