using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\w+(?=:)";
string substitution = @"""\g<0>""";
string input = @"{
pzn: ""09900426"",
url: ""/url.html"",
packageSizeValue: ""28"",
packageSizeUnit: ""St"",
sizeValue: "",
potency: ""
}, {
pzn: ""09900432"",
url: ""/url2.html"",
packageSizeValue: ""84"",
packageSizeUnit: ""St"",
sizeValue: "",
potency: ""
}";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}