const regex = new RegExp('\\w+(?=:)', 'g')
const str = `{
pzn: "09900426",
url: "/url.html",
packageSizeValue: "28",
packageSizeUnit: "St",
sizeValue: "",
potency: ""
}, {
pzn: "09900432",
url: "/url2.html",
packageSizeValue: "84",
packageSizeUnit: "St",
sizeValue: "",
potency: ""
}`;
const subst = `"\g<0>"`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);