# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\w+(?=:)"
test_str = ("{\n"
" pzn: \"09900426\",\n"
" url: \"/url.html\",\n"
" packageSizeValue: \"28\",\n"
" packageSizeUnit: \"St\",\n"
" sizeValue: \"\",\n"
" potency: \"\"\n"
"}, {\n"
" pzn: \"09900432\",\n"
" url: \"/url2.html\",\n"
" packageSizeValue: \"84\",\n"
" packageSizeUnit: \"St\",\n"
" sizeValue: \"\",\n"
" potency: \"\"\n"
"}")
subst = "\"\\g<0>\""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.