using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\d+:\d+(?::\d+)?(*SKIP)(*F)|:\w+";
string input = @"2018-05-21T00:00:00+02:00
00:00:00
00:00
:light at 07:15:0000";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}