re = /\d+:\d+(?::\d+)?(*SKIP)(*F)|:\w+/m
str = '2018-05-21T00:00:00+02:00
00:00:00
00:00
:light at 07:15:0000'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end