// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\d+:\d+(?::\d+)?(*SKIP)(*F)|:\w+").unwrap();
let string = "2018-05-21T00:00:00+02:00
00:00:00
00:00
:light at 07:15:0000";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}