const regex = /:[A-Za-z_]\w*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp(':[A-Za-z_]\\w*', 'gm')
const str = `2018-05-21T00:00:00+02:00
00:00:00
00:00
:light at 07:15:0000`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}