$re = '/:[A-Za-z_]\w*/m';
$str = '2018-05-21T00:00:00+02:00
00:00:00
00:00
:light at 07:15:0000';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);