import re
regex = re.compile(r":[A-Za-z_]\w*", flags=re.MULTILINE)
test_str = ("2018-05-21T00:00:00+02:00\n"
"00:00:00\n"
"00:00\n"
":light at 07:15:0000")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")