import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\S\\S\\K(?=\\S\\S)";
final String string = "\n"
+ "2\n"
+ "22\n"
+ "223\n"
+ "2233\n"
+ "22334\n"
+ "223344\n"
+ "2233444\n"
+ "22334455";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}