const regex = /\S\S\K(?=\S\S)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\S\\S\\K(?=\\S\\S)', 'gm')
const str = `
2
22
223
2233
22334
223344
2233444
22334455`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}