$re = '/\S\S\K(?=\S\S)/m';
$str = '
2
22
223
2233
22334
223344
2233444
22334455';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);