#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\€?(\d{1,3}[.](\d{3}[.])*\d{3}|\d+)([,]\d{1,2})?$"
Local $sString = "2345678914564644,61" & @CRLF & _
"€1.000.000,21" & @CRLF & _
"1.123.123" & @CRLF & _
"€0000000" & @CRLF & _
"€1.123.123,12" & @CRLF & _
"€1,123,123" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")