const regex = /^\€?(\d{1,3}[.](\d{3}[.])*\d{3}|\d+)([,]\d{1,2})?$/m;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\€?(\\d{1,3}[.](\\d{3}[.])*\\d{3}|\\d+)([,]\\d{1,2})?$', 'm')
const str = `2345678914564644,61
€1.000.000,21
1.123.123
€0000000
€1.123.123,12
€1,123,123
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}