re = /^\€?(\d{1,3}[.](\d{3}[.])*\d{3}|\d+)([,]\d{1,2})?$/m
str = '2345678914564644,61
€1.000.000,21
1.123.123
€0000000
€1.123.123,12
€1,123,123
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end