using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\((\d+)\)\s+([^\(]+)\(([^\)]+)\)\s+vs\.\s+\((\d+)\)\s+([^\(]+)(.*)$";
string input = @"(8) Cincinnati (22-10) vs. (9) Purdue (21-12)";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}