package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^\((\d+)\)\s+([^\(]+)\(([^\)]+)\)\s+vs\.\s+\((\d+)\)\s+([^\(]+)(.*)$`)
var str = `(8) Cincinnati (22-10) vs. (9) Purdue (21-12)`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}