using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s*(.+?)\s*=\s*'(.+?)'\s*(OR|AND)?";
string input = @"f = '1' OR f = '2'
s = '3' OR s = '4' OR s = '5'
t = '6'
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}