re = /\s*(.+?)\s*=\s*'(.+?)'\s*(OR|AND)?/m
str = 'f = \'1\' OR f = \'2\'
s = \'3\' OR s = \'4\' OR s = \'5\'
t = \'6\'
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end