import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\s*(.+?)\\s*=\\s*'(.+?)'\\s*(OR|AND)?";
final String string = "f = '1' OR f = '2'\n"
+ "s = '3' OR s = '4' OR s = '5'\n"
+ "t = '6'\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}