using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?:[2-9]|\d{2,})\b";
string input = @"/page/0/
/page/1/
/page/10/
/page/11/
/page/15/
/page/2/
/page/20/
/page/21/
/page/201/";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}